Oprius does not officially support your web browser at this time. We highly recommend installing our favorite web browser, Google Chrome. You can continue to use your current browser, but may experience some problems.

What Browsers Do We Support?

Fully Supported




Unsupported Browsers (may still work)





Not Recommended (known incompatibilities)


Why Do I Need To Upgrade?

Oprius does all kinds of fancy things like allowing you to drag things around and load data behind the scenes to make Oprius faster. We need you to be running an up to date browser for Oprius to work properly. We highly recommend Google Chrome (it works much better then Internet Explorer). For you technical folks, we need certain DOM and JavaScript capabilities that are either not or poorly implemented in older browsers.

Oprius Supportsupport@oprius.com